(glﬁgen

MAX Communication Server
Release 8.5 Update 1

UC Deployment Guide

July 2018



( élﬁgen

Contents
ADOUL TS GUIE ..eeeieieiteetee ettt ettt e s bt e s et e s it e e sa bt e s ab e e sab e e s bt e s a b e e eabeesabeeeabeesabeeeabeesabeesnneesabeesaseenares 3
Related DOCUMENTATION. ...ttt b et ettt s at e sh e e bt et e e st e sabesebesbeesbeesbee bt smtesaeeeneenbeenbeens 3
OVEIVIBW ...ttt ettt ettt et b e e b e e e bt e e b e e e bt e e b e e e bt e e b b e e b e e e b b e e b et e ba e e be e e b e e e be e e b e e s be s e ba e e be e e baeere e s 3
[Y=Te LU= 0 =T o PPN 3
Configure MaxXCS BEHING NAT ...coo ettt et e e ettt e e s te e e e st e e e sateee s aaeaeesstaeeeansseeessseeeasseeeeansseeesssneeenssenennnes 3
Create an Address Record and SRV RECOITS .......coviiiiriiiriiiiiiiieneceeereert ettt et st r e s s s 4
(0700 Y 7= {0 T N 1Y =D O R USRSRN 5
Configure User Call INTEGIatioNn ..........iiiiiiiiiieee ettt ettt et e sbt e et e e bt e s bt s sbbe s bt e e sbbeebeesabbesneeen 7
(00T Y iT={V =Y o] o 1 OSSR SRR 8
(0o Ty T ={U T =Y o o 1 = S 9
Routing Skype for Business Unanswered Calls to MaxCS VOIiCEMAil ....ccuueiiiiieeieiiiiecceiis et scee e esee e 9
VEIHICATION ..ttt ettt et e bttt a b e shee s bt e b e e bt et e e ateeateehe e bt an bt eabeeabesabesheesheeabeebesabesatesatenbeebeens 10
OFNEE USEI UC OPTIONS ..ttt ettt ettt ettt ettt ettt e st e e sbte s bt e s bt e sttt e bt e sab et abeesabe e s bt e sabeesabeesabeesaneesabeesaneesans 10
(0] oI = Yu oY =1 W N Ta oY =Y o o [OOSR SUR 10

NOTICE: While every effort has been made to ensure accuracy, Altigen Communications, Inc., will not be liable for technical or
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About This Guide

This document is provided for AltiGen Partners who will be deploying AltiGen’s hosted Skype for Business service
for a customer with MaxCS Release 8.5 Update 1.

You can order the hosted Skype for Business services on AltiGen’s Cloud Portal.

Related Documentation

Additional deployment information for Release 8.5 Update 1 can be found in the following documents, which are
available in the Altigen Knowledgebase.

e  MaxCS 8.5 Update 1 New Features Guide

e The Exchange Integration chapter in the MaxCS 8.5 Update 1 Administration Manual
e MaxCS 8.5 Update 1 Deployment Guide

e  MaxCS 8.5 Update 1 Upgrade Guide

Overview

AltiGen’s Skype for Business service is supported only on AltiGen’s hosted Skype for Business offering. Support for
Skype for Business hosted by other service providers is not supported.

Requirements
Your environment must meet the following requirements:
e  MaxCS must already be installed.

e  Your Unified Communications (UC) account must already be configured, and you must be able to log in as
a Skype for Business user and use the basic Skype for Business tasks.

e MaxCS must have a public IP address and must be properly configured behind NAT. See the next section
for instructions.

e The MaxCS server must have a public FQDN. If don’t have an existing domain, you will need register a
domain from a Domain Name Registrar in order to obtain a public domain. You must create an SRV
(Service Record); see page 4 for instructions.

Configure MaxCS Behind NAT

You need to configure MaxCS and the NAT router so that MaxCS works properly behind NAT.

Important! If your firewall/NAT router supports SIP, you must FULLY disable this feature on the firewall/NAT
router. If you do not disable the feature, then conflicts may occur between MaxCS and the
firewall/NAT router. Those conflicts may cause remote IP phones to not behave properly.

1. Make sure the MaxCS system uses a private static IP address, for example, 10.10.0.8. Do not use DHCP on the MaxCS
system.

2. In Enterprise Manager, define the range of the local IP addresses. Make sure the MaxCS system is
included in the range. If the range is not defined correctly, IP phones will not work.
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3. Setlocal IP network ranges to private. Multiple private networks can be added.
4. Onthe IP Networks tab, in the NAT Support group:
e Check Enable SIP NAT support.
e Enter the Public IP address of the router in the Public IP Addresses section.
e Do not check the Enable Virtual IP Addresses Support option.

5. Configure the NAT/firewall to forward TCP ports 10025, 10027, 10032, 10037, 10050, 10064, 1720 and
UDP ports 69, 5060, 10060 to MaxCS.

6. Configure the NAT router to forward to MaxCS UDP ports 49152 ~ 49152 + ipresno * 2 where:
e ipresno is the number of the IP resource channels in the system
For the MAX1000 system, it would be UDP ports from 49152~49211 (30 IP resource channels).

An easy way to find out the RTP/TCP port ranges for SIP is to look in the Current Resource Statistics
window in MaxCS Administrator (View > Current Resource Statistics). All ports are listed in the Local Ports
column.

Create an Address Record and SRV Records

An SRV (Service) record provides information on available services for your systems, most commonly used with SIP
configuration. You will create one or more SRV records. You will also create an A (Address) Record, which is used to
point your host name or domain name to an IP Address.

In this example, [yourdomainname] is used as the domain of your company.

1. Work with your Domain Name Registrar to set up an A Record that points to the IP address of your MaxCS
server. We recommend that you use ‘maxcs’ as the host portion of that A Record. Here is the recommend
format:

maxcs. [yourdomainname] .com
2.  Work with your Domain Name Registrar to set up one or more SRV records.

There can be multiple SRV records of the same name; if so, then the priority and weight values of those
records determine how calls are distributed. Here is the format:

_sip. udp.maxcs. [yourdomainname].com
weight: 10

priority: 10

target: maxcs. [yourdomainname].com
port: 10060

Where:

_sip._udp.maxcs.[yourdomainname].com = tells how to deliver UDP SIP calls to the MaxCS server.

weight = A relative weight for records with the same priority, higher values are preferred. We recommend
that you set this to 10.

priority = The priority of the target host. The lower the value in the priority field, the more preferable the

associated target. 0 is the highest priority (lowest number). We recommend that you set this to
10.
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target = This should be the A Record that you set up in step 1. It points to the IP address of your MaxCS
server.

After the record has been created, it may take several hours for the propagation process to finish. The
configuration will not work properly until the FQDN is fully propagated.

At this point, you must contact your AltiGen Skype for Business Hosting team to configure routing
policies for outbound Skype for Business calls through MaxCS.

Configure MaxCS

1.

2.

On the MaxCS server, open a command line. Type following instruction:

nslookup maxshc.sfbhosting.com

[z Administrator: Command Prompt

Microsoft Windows [Version 6.1.76811]
Copyright ¢c) 280? Microsoft Corporation. All rights reserved.

C=sUserssAdninistratorinslookup maxshc.sfbhosting.com
Gerver: zeus_altigen.com
Address: 108.10.68.38

Non—authoritative answer:
maxshc .sfhhosting.con
: 69.175.183.5
69.175.183 .13

Figure 1: The command returns two addresses

The command will return two addresses. In our example, the addresses are 69.175.103.5 and
69.175.103.13.

Write down the addresses that your system returns. You will create new entries in the IP dialing table for
each one, during step 4.

In MaxCS Administrator, select VolP > Enterprise Network Management. Click the Codec button at the
top. Create a profile called maxsbc with following settings:
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Profile Setting

Mame: maxshe

Selected Codec Available Codec

G711 Mu-Law C = Add ) G711 A-Law
G7231
{ Remave--> ) By
Codec: G722

Cw )
Diown )

Video Codec: D Enable H264 Codec

DTHMF Delivery ( RFC 2833

SIP Early Media ( Disable

SIP Transpart (uor

Figure 2: A new codec profile "maxsbc"
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3. Inthe IP Dialing table, add an entry. The Server Name and Service IP Address entries MUST exactly match
the entries in the following figure.

Server ID: | 100 %]
Sener Marmne: |maxsbc.sfbhusting.cnm |
Serer IP Address: |maxsbc.sfbhusting.cnm |
Remate Ext Lenath:  none -
Cialing Scheme: " Enblock -
Protocal: (sP -
Codec:; ( maxshe -
Hop OFF Allowed: (fes -
SIP Source Port: (10060 -
SIP Destination Port: |1DDED

Figure 3: New entry in the IP Dialing Table
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In the IP Codec table, create two new entries; one entry for each of the two addresses that were returned

from the command line that you ran in step 1 on page 5. In our example, 69.175.103.5 is one of the IP

addresses that was returned in step 1.

- Add IP Device Range -
From: |63.175.103.5 |
To: |63.175.103.5 |
Codec: £ maxshe v
| O ) . Cancel )

Figure 4: Create two new entries in the IP Codec table, one for each returned address from step 1

5. In MaxCS Administrator, select System > Unified Communication Configuration. Check the option Enable
UC Integration and set your trunk access code.

e
Systern  PBX  Call Center

System Configuration. ..

‘roice Mail Configuration, .
Af Configuration. .,

Recording Configuration. .,

Palycom Configuration. ..
Request Certificate

VoIl Report

Softswitch Component Management. ..

Mulkilingual Configuration, .

Application Ext Configuration. ..

Unified Cammunications Configuration. ..

User Management...

Figure 5: The System menu

Unified Communic- .ions Configuration

[@"_onfiguration Inkegration
[V Enable LC Integration

Default Trunk Access Code:

E—

Ok | Cancel |

Apply |

Figure 6: Enable UC integration for the MaxCS system

5. Contact your AltiGen SfB hosting team to configure routing for outbound SfB calls through MaxCS.

Configure User Call Integration

There are two different choices for call integration. Choose the configuration that works best for users in your

organization.
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The two configuration options differ only in how incoming PSTN and MaxCS extension-to-extension calls are
routed. (There is no difference in how outgoing calls are handled.)
e Configuration A: Incoming calls go to the user’s MaxCS extension

e Configuration B: Incoming calls are forwarded to the Skype for Business client (not supported for
Workgroup or Huntgroup members)

Important! When configuring MaxCS users who are members of a Workgroup or a Huntgroup, do not
use Configuration B. These users must be set up with Configuration A. Otherwise,

Workgroup and Huntgroup calls will not be routed to them.

TN

ooo

MaxCs extension Skype client

onfig B
N/ (]U

L
i | 5N

Incoming MaxCS extension-to-
extension calls and
PSTN calls

Figure 7: Two options for configuring incoming PSTN and MaxCS extension calls

Configuration A
Configuration A will send incoming PSTN and MaxCS extension-to-extension calls to the user’s MaxCS extension.
1. In MaxCS Administrator, select PBX > Extension Configuration.

2. Inthe left panel, select the extension. (Our example uses extension 228.) On the General tab, set the
following parameters:

o  Check the option Enable Unified Communications.

e Forthe SIP URI field, enter the corresponding SIP URI. (Our example is sip:john@qualtigen.com.)

e Make sure that Line URI matches the Skype for Business Account’s Line URI. In our example, this is
+14085979028.

— Unified Communicationz

v Enable Unified Communications
SIP URI:

Isip:iahn@qualtigen.cam

Line LRI
Tal |+‘| 4085973028

Figure 8: Enable UC for a user
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3. Loginto MaxAgent/MaxCommunicator as this user. You should see the presence updating.

I Maxfgent

John Lin (228) © Online/

Jl\ll'lf'-lE

ORI 8

Record | State Name | Nurmb

Figure 9: Log into the client and check that the user's presence updates

Configuration B

Configuration B will forward incoming PSTN and MaxCS extension-to-extension calls to the Skype for Business

client.

Note: Do not use this configuration for any users who are members of a MaxCS Workgroup or Huntgroup. If you
do so, those users will not receive Workgroup or Huntgroup calls.

The settings for Configuration B are the same as for Configuration A, with one additional parameter:

e  For the extension, on the Answering tab, set the Enable Forward to option to UC Client. You must
also set the Ring Time option to a shorter period than is set in the user’s Skype for Business client
(Tools > Options > Call Forwarding), so that MaxCS can handle the RNA condition.

|
| General I Group | Speed Dialin
Restriction Answering

Forward &l Calls
¥ Enable Forward to ||_||: Client * 'I

I

Figure 10: An extra option must be set to configure a user for Configuration B

Routing Skype for Business Unanswered Calls to MaxCS
Voicemail

This feature applies only those organizations which do not have voicemail integration with Exchange online.

You can configure extensions so that unanswered Skype for Business incoming calls will be forwarded to the
extension’s MaxCS voicemail. One limitation of this feature is that users will not be able to access their MaxCS

voicemail messages from their Skype for Business clients.

To configure this forwarding, the user follows these steps:
1. Inthe Skype for Business client, choose Tools > Options.
2. Inthe left menu, select Call Forwarding.

3. Click the Unanswered calls will go to option.
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Your current call forwarding settings:

Calls will ring you at !&kj—l (408) 555-5176.
Unanswered calls will go 10: Yoice Mail in 20 seconds

These settings will apply:  All the time

4. Inthe next dialog box, select New Number or Contact.

5. Inthe panel that opens next, enter your extension number preceded by an asterisk character (*). For
example, if your MaxCS bound extension number is 678, you would enter *678.

Call Forwarding - Unanswered Calls x
Send unanswered calls to the following: \ =678 “
Ring for this many seconds before redirecting: 20 -

6. Specify how many seconds to wait before forwarding the call.

Verification

Verify that the configuration works correctly.

1. Login as a Skype for Business user. Place outbound Skype for Business calls and make sure that the calls
go through the MaxCS server.

2. Place test calls to verify that inbound calls are correctly routed correctly. Check that inbound calls to both
Configuration A and Configuration B users work correctly.

Other User UC Options

For descriptions of other user UC options, including the user option to dock the Skype for Business client window
and the option to map an agent’s voicemail greetings to Presences, refer to the MaxCS client documentation (the
MaxAgent Manual or the MaxCommunicator Manual).

Operational Limitations

In some cases, phones may not hang up when the user end a Skype for Business conference call. The phone will
hang up once the last conference participant ends the conference call.

For a full list of open issues in this release, refer to the readme files.
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